Forum: Bug Reports

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support and general questions related to GEO my WP plugin and its core add-ons please use the support forum.

Blank Page after Publish and State not saving…

Forums Bug Reports Blank Page after Publish and State not saving…

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29776
    webcon
    Member

    Hello,

    I have been integrating your plug-in for a client of mine and I have noticed a couple issues that I wanted to bring to your attention.

    1. When I first installed the plug-in and tried to save my first location, I got a blank screen. It was because I was getting the Google Maps API Limit Reached message. In your code (/includes/functions.php) around line 33 a call to write the message to the JavaScript Console. However, at this point in the process the main wordpress headers have not yet been printed. Therefore, an error occurs when WP finally tried to print its headers. I modified the code to write the message to the PHP error log rather than the JS Console.

    I changed:

    To:
    error_log('google geocode gets OVER_QUERY_LIMIT');

    I’m hoping this change or a similar one will makes its way into the next version so that my clients site does not break when they update the plug-in.

    The next issue I found was that the state was not saving in the “State” field. It appears in the $post->address fields, but not in the $post->state field. And upon editing any of my locations, the “State” field continues to be blank.

    To get around this (for anyone having a similar issue), I added the following to my custom results template prior to printing the address:

    Of course, I’m dealing with all US addresses and I do not know how this would effect Non-US addresses.

    Thanks.

    #29780

    Hi Wbcon,
    Thank you for the post and the quick fix.
    I am already aware of the issue with the OVER_QUERY_LIMIT message and it is already fixed in the next update. That line was for my self for testing purposes which i forgot to remove before releasing it.

    The other issue you are having i does not happen in any of my test sites. Are you using the latest version of the plugin?
    Also, are you saving the posts from the admin page or using an add-on or any other script to save them?

    #29779
    webcon
    Member

    I am using version 2.1 and I’m saving from the admin page. See attached. You can see that the state is not filled in. Even if I enter the state manually and click “Publish/Update”, it will not save. When I search for an address, it does fill in the State field, however, once published/updated, the state field is once again blank.

    I’m using a custom post type created by the Types plug-in. Not sure why that would make a difference since it is saving all the other fields perfectly. But maybe the Types plug-in is doing something strange with your state field.

    Other plug-ins/Versions to note:
    WordPress v3.6
    WordPress SEO v1.4.15
    Types v1.4.0.1
    bbPress 2.4
    Gravity Forms v1.7.7

    Thanks.

    #29778
    webcon
    Member

    Eyal, any word on this issue. I disabled all my plug-in except for Types (since that is what I’m using to create the custom post type) and the problem remains. If I have some time, I’ll add GeoMyWP to the default “post” type and see if the state field saves. At least that will let us know that the issue is with either any custom post type or custom post types created by the Types plug-in.

    Thanks.

    #29777

    Hi,
    That will be helpful. It is hard for me to tell what the issue since it doesn’t happen on any of my sites.
    Also, i have been working on the Support in the post page redoing all of it. So hopefully with the new code what ever the issue you are having will go away.
    I will have beta ready by Sunday or Monday so let me know if you’d like to test it.

    Tahnk you
    Eyal

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.