Forum: Premium Settings

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Premium Settings premium extension please open a new premium support ticket.

[Resolved]Custom Map Icons

Forums Premium Settings Custom Map Icons

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #50566
    perriangela
    Member

    I’ve looked everywhere to find the answer and this post — https://docsdep.geomywp.com/forums-site/topic/custom-icons-and-svg-file-type/ — almost answers my question but I’m confused as to where I’m supposed to put my custom map icon .pngs.

    I’ve never worked with child themes. Do I put them in my theme directory or the plug-in directory?

    And do I have to create these directories or do they already exist?

    Thanks so much!

    #50569

    Hi Perriangela,
    since you are not using a child theme, than in your theme’s folder you should create the folders
    geo-my-wp/posts/map-icons/ for Post Type Locator map icons
    and the folders
    geo-my-wp/fields/map-icons/ for Members Locator map icons

    and place your png icons in there.

    Let me know if that helps.

    #50571
    perriangela
    Member

    Thanks Eyal!

    Of course immediately after I submitted my ticket, I found where the category- and map-icons are located in the GMW Premium Settings folder. I put my icons in there for the time being (knowing they’d be overwritten in an upgrade) and things worked for my posts’ Global Maps. They didn’t, however, work for my Single Location Maps (it was still the red default marker).

    After your reply, I did what you said to do (but I didn’t delete the icons I had already put in the Premium Settings folder) and when I went to my Global Maps all markers had disappeared. My Single Location Maps still had the red default marker.

    Does it make a difference that my GMWP version’s folder name is “geo-my-wp 2” and I named the folder I created under my theme “geo-my-wp”? Or should I have deleted the icons I had already put in the plug-in’s folder?

    And what needs to be done to change my posts’ markers on their Single Location Map to the same marker I’ve designated for them for Global Maps?

    Thanks so much!

    #50601

    They didn’t, however, work for my Single Location Maps (it was still the red default marker).

    At the moment, the Premium Settings map icons feature controls only the maps of GEO my WP search forms. For the Single Location map you can use the “item_map_icon” shortcode attribute or the widget settings to set the URL of the map icon that you want.

    Does it make a difference that my GMWP version’s folder name is “geo-my-wp 2” and I named the folder I created under my theme “geo-my-wp”? Or should I have deleted the icons I had already put in the plug-in’s folder?

    It shouldn’t make a difference if the plugin’s folder name is anything other than geo-my-wp, even though it is not recommended. But in your theme’s folder the folder’s name must be geo-my-wp.

    After your reply, I did what you said to do (but I didn’t delete the icons I had already put in the Premium Settings folder) and when I went to my Global Maps all markers had disappeared.

    I believe that after adding the map icons to the theme’s folder you need to set the map icons feature in the form editor again.

    Try that and let me know if it works.

    #50643
    perriangela
    Member

    Thanks! I’ll try it tomorrow to see if it works.

    #50729

    This topic marked “Resolved” due to inactivity. If you wish to reply to this topic please change its status to “Not resolved”  before replying.

    #52625

    Hi there,
    I need to install custom members icons to be visible in Global Maps. I have the following plugins:

    GEO my WP
    GMW Add-on – Global maps
    GMW Add-on – Premium Settings

    Then, I have created the folder: wp-content/plugins/geo-my-wp/fields/map-icons/ where I upload my custom icons. But I can’t see the custom icons, neither in user’s profile dashboard or wp dashboard -> Global Maps settings.

    Thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.