Forum: Global Maps

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Global Maps premium extension please open a new premium support ticket.

[Resolved]Error displaying [gmw map="1" name="form_id_1"]

Forums Global Maps Error displaying [gmw map="1" name="form_id_1"]

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #52645

    Hi, have the global maps plugin. Made a form and inserted it in a page:

    Historien på gaden

    and get this:

    Fatal error: Call to undefined function gmw_pt_form_post_types_dropdown() in /home/www/ on line 42

    This error is also mentioned in another support ticket: “[Resolved]Blank for map display”. This ticket is not really resolved, its only marked so due to inactivity. I have Geo My wp 2.6.5 and Global Maps 2.0


    Hello Claus,

    1) Do you have a plugin or a custom function that changes the activation order of the plugins?

    2) Please deactivate both GEO my WP and Global Maps plugins then activate them back to see if it helps.

    Private Content Hidden

    Hi Eyal

    Thanks for your reply.

    My wp is recently installed with Ubergrid theme. No custom-changes have been made apart from a few changes in the style.css file. And no custom-made plugins are installed.

    I’ve deactivated both Geo my wp and Global Maps, which didn’t change the error-message. After that I deactivated the other plugins one by one. Still the same error-message.

    I then activated another Theme and the same error-message is still there.

    Then I inserted the gmw_pt_form_get_post_types_dropdown function directly into search-form.php which removed the error and produced the map but with a form thats not clickable. Just to see if the function is undefined because the link between search-form.php and gmw-pt-template-functions.php is somehow broken.

    regards Claus


    By the way: When I’m in the backend editing the form in question the following warning is displayed:

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/www/ on line 492

    Maybe there is a connection?


    OBS: So sorry, Eyal, one of the core add-ons was deactivated. I just realized that the plugin only works if it is activated. Now it seems to work. My mistake.


    Ah, that makes sense. And thank you for the details.
    I need to update the add-on and make sure that there is a warning saying that the core add-on need to be activated and to prevent the error message from showing.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.