Forum: Geo Job Manager

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Geo Job Manager premium extension please open a new premium support ticket.

[Resolved]Error from API in browser

Forums Geo Job Manager Error from API in browser

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #52276

    Hello,

    I’m getting this in the inspector http://cl.ly/gDss
    Is there something I need to set up that I have not perhaps?

    On some pages the map does not render either http://cl.ly/gDlF EX: http://184.173.68.16/liberty/doctors/the-pediatric-practice-an-affiliate-of-evermed-dpc/
    Any idea what would cause that?

    Thanks,
    Andrew

    #52277

    Looks like some of the cluster markers are missing now too http://cl.ly/gDkJ

    #52278

    Also, I have never been able to successfully order the names of the posts. I tried every single thing I could find. What happens is that not everyone once to let the app use their location. Once they select no, the listings are random as could be. And none of them have any effect on order.

    Sorry for all the issues, I can open in another ticket but they may be related.

    Thanks,
    Andrew

    #52281

    Hello Andrew and thank you for the purchase.

    I’m getting this in the inspector http://cl.ly/gDss
    Is there something I need to set up that I have not perhaps?

    The first warning is from Google Chrome browser. Google has disabled the browser locator for non secured pages. Which means that if your site does not have SSL certificate installed, then users won’t be able to use the current location feature. Unfortunately, there is nothing to do about that.

    The second warning just means that there is no API key provided but that should not concern you as it is not required for the plugin to function. I will look into removing this warning in a future release.

    On some pages the map does not render either

    When the map is not showing most likely means that there is no location data saved in Job manager Geolocation table in database. Please navigate to the admin’s “Edit Job” page of the job with a missing map and click the “Update” button to re-save the job. By doing so it should trigger the geocoder and hopefully the location data will be created. You can confirm that the location data exits by looking for the custom fields geolocation_street, geolocation_city, geolocation_state and so on.

    Let me know if that helps.

    Also, I have never been able to successfully order the names of the posts. I tried every single thing I could find. What happens is that not everyone once to let the app use their location. Once they select no, the listings are random as could be. And none of them have any effect on order.

    If there is no location entered in the address field ( manually or using the locator ) then the default order by WP Job manager plugin is random. What have you tried to do in order to change that?

    #52327

    The first warning is from Google Chrome browser. Google has disabled the browser locator for non secured pages. Which means that if your site does not have SSL certificate installed, then users won’t be able to use the current location feature. Unfortunately, there is nothing to do about that.

    I’m not sure I follow you on this. We do not have SSL installed but the locator seems to be working on some occasions.

    When the map is not showing most likely means that there is no location data saved in Job manager Geolocation table in database. Please navigate to the admin’s “Edit Job” page of the job with a missing map and click the “Update” button to re-save the job. By doing so it should trigger the geocoder and hopefully the location data will be created. You can confirm that the location data exits by looking for the custom fields geolocation_street, geolocation_city, geolocation_state and so on.

    Unfortunately, resaving did not do the trick. Even if it did, going into hundreds of locations and configuring each one is not realistic at all. The biggest issue is that they are not showing in the map either. So they dont show in the map nor does the map show. I’m missing more than half of my entries.

    If there is no location entered in the address field ( manually or using the locator ) then the default order by WP Job manager plugin is random. What have you tried to do in order to change that?

    I’m pretty sure these are not ordering because they are not geocoding for some reason. I bet once we get that map to show, they will order properly.

    That all being said, the most important thing here is to get this map to show. I’ve spent an enormous amount of time on this project. Whatever you can do to help me get this map working consistently would be awesome.

    Thanks,
    Andrew

    #52345

    Hi,

    I’m not sure I follow you on this. We do not have SSL installed but the locator seems to be working on some occasions.

    This should not be the case. When using Chrome browser without SSL and using the locator button, an alert message saying “User denied the request for Geolocation” should be displayed automatically. Regardless if that is the case or not, the first error message is regarding Google Chrome deprecated the browser locator on non-secured pages.

    Unfortunately, resaving did not do the trick. Even if it did, going into hundreds of locations and configuring each one is not realistic at all. The biggest issue is that they are not showing in the map either. So they dont show in the map nor does the map show. I’m missing more than half of my entries.

    Unfortunately, there is not much to do about that. A Job will only show on the map if it has geolocation data attached to it. That location data should be processed via WP Job Manager plugin when creating or updating a job. Now, if updating the job did not geocode the address properly then it could be the results of OVER_QUERY_LIMIT issue. Navigate to the “Edit job” page of one of the jobs that don’t show on the map and see if the geolocation custom fields exists. If no geolocation custom fields exists then you should try this plugin. The plugin will use Client-side geocoder to geocode the job’s location which should overcome the OVER_QUERY_LIMIT issue, if that is the case for you.

    The plugin adds a new “Geocode address” button below the address field of the “Edit Job” page. You need to click on it to geocode the address then update the job.

    Let me know if that helps.

    #52471

    This topic marked “Resolved” due to inactivity. If you wish to reply to this topic please change its status to “Not resolved”  before replying.

    #52574

    The plugin indeed worked. However, there are hundreds of posts. The whole project requirement was all about importing these using https://wordpress.org/plugins/wp-job-manager-xml-csv-listings-import/. Perhaps there is a setting or something in the import feature that is causing this?

    Is there a way to bulk geocode them? That would be perfectly fine.

    Any idea what causes some to not geocode and other to do so fine?

    Thanks,
    Andrew

    #52575

    Hello Andrew,

    The whole project requirement was all about importing these using https://wordpress.org/plugins/wp-job-manager-xml-csv-listings-import/. Perhaps there is a setting or something in the import feature that is causing this?

    I apologize, but I am not familiar with the importer plugin so I cannot give you an answer. you should contact the developer of the importer plugin for that.

    Is there a way to bulk geocode them? That would be perfectly fine.

    Not at the moment ( not a way that I know of at least ). Bulk geocoding can be problematic mainly because of the OVER_QUERY_LIMIT issue which limits you to 2500 geocoding per 24 hours. A better bulk geocoding system can be done better ( which might overcome the OVER_QUERY_LIMIT ) using client-side geocoder and AJAX. But it can take a good amount of work to create such system.

    Any idea what causes some to not geocode and other to do so fine

    My best guest is as mentioned above; the OVER_QUERY_LIMIT issue. Google API limits the geocoding for 2500 queries per 24 hours per IP address. Once the limit is reached, geocoding on your site will be blocked until the next day. Most cases OVER_QUERY_LIMIT happens when a site is on a shared server which also means that other sites on the same server of your site will share the same IP address. In such case, if other sites on the same server are using Google API features they might be “eating up” the geocoding queries.

    I hope that makes sense.

    #52594

    I set things up locally and everything geocoded. So it may be the OVER_QUERY_LIMIT issue as you suggested.

    Would having the site on a dedicated IP address help at all here?

    #52599

    Hi Andrew,

    Only because I can only assume that the shared server/IP address causes the issue, I can’t say for sure that a dedicated IP address would help. However, based on other users that had the same issue and either switched to another server provider or moved to dedicated IP address and the problem was solved, I believe that a dedicated IP address would solved the issue for you as well.

    #52631

    Ugh, many hours later… the dedicated IP did not help. I set the entire site up using a dedicated IP and the issue persists.

    The listings are geocoded locally. So I thought, well I can use the export from the local version and import to the live version. Just Geocode locally… When I import the listings from the local set up where they are geocoded, they import into the live site NOT geocoded. How can that be possible? That tell me this is not the query limit if they are already geocoded and it may be something host related or something else in the environment. Any other ideas?

    Thanks,
    Andrew

    #52632

    Are you using V2 or V3 of Google Maps API? I saw somewhere that V3 would made some adjustments for this limitation.

    Could you add an option for the plugin where users could use their own API key?
    Or a way to get the user to use a business account?

    Thanks,
    Andrew

    #52633

    HI Andrew,
    I am sorry it didn’t work out, which is weird. It worked for A few other users who tried the dedicated IP solution.

    Regarding the import of the location; The geolocation information is saved in two locations:

    1) In custom fields – this is where WP Job Manager plugin saves the geolocation information after geocoding a location.

    2) In custom table in database – this is where Job Manager Geolocation add-on saves the geolocation information to have a better performance when doing a proximity search.

    SO, when importing the locations you need to make sure that custom fields are being imported as well. This way the geolocation information that is save in the custom fields will also exits in the live site. Once the importing is done you then need to navigate to the Job Geolocation Settings page and click the “Import” button. This importer will import the geolocation data from the custom fields into the geolocation custom table in database.

    Does that make sense?

    Are you using V2 or V3 of Google Maps API? I saw somewhere that V3 would made some adjustments for this limitation.

    The plugin uses Google Maps v3.

    Could you add an option for the plugin where users could use their own API key?
    Or a way to get the user to use a business account?

    This question you should refer to the developer of WP Job Manager plugin. WP Job Manager plugin is the responsible for the geocoding and I believe that there is a filter that you can use in order to add an API key. At the same time you can describe the issue that you are having with the geocoder. Maybe be they will have another/better solution for you ( than my solution ).

    #52639

    Just another day in the life… thanks for the hand. I’ll reach out to WPJM. I see some other folks having similar issues. I thought that functionality was coming from your plugin. Thanks again for the hand.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.