Forum: Feature Requests

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Feature Requests premium extension please open a new premium support ticket.

[Resolved][gmw form="results"] on same page as [gmw form="2"]

Forums Feature Requests [gmw form="results"] on same page as [gmw form="2"]

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #50879
    gsh2000
    Member

    Eyal hello again:

    Thanks for all your help.

    Trying something, but running into issue that I have not been able to solve:

    I have a search box [gmw form=”1″] appear on my homepage, that displays the results on my results-page. That all works nice… I have [gmw form=”results”] on my results-page.

    But, I also have a [gmw form=”2″] on top of my results-page, that enables the user to re-submit a more granular search (with dropdown taxonomies, etc.) — and yes, you guessed it… I have a recursive problem. Search results show *twice* on 2nd search.

    Is there a shortcode parameter to have [gmw form=”results”] apply only to one specific form? Any suggestions? Obviously, I can create/send the user to a new page to submit [gmw form=”2″], but trying to avoid this.

    Also, while I have you, if I have Auto Locator enabled, should I expect current location to automatically show in search box field, without clicking? There is a shortcode to echo Auto Locator location? (e.g. I would like to display users their City, automatically upon them visiting my hompage)

    Thanks, Garry , Los Angeles

    #50880

    You are welcome Garry, I am glad can help.

    Is there a shortcode parameter to have [gmw form=”results”] apply only to one specific form? Any suggestions? Obviously, I can create/send the user to a new page to submit [gmw form=”2″], but trying to avoid this.

    For your case you can simply use [gmw search_form=”2″] to only display the search form with ID 2. So on submission you will see only one set of results produced by [gmw form=”results”]. However, you could also use [gmw search_results=”1″] and [gmw search_results=”2″] to display the results of a specific form.

    Also, while I have you, if I have Auto Locator enabled, should I expect current location to automatically show in search box field, without clicking? There is a shortcode to echo Auto Locator location? (e.g. I would like to display users their City, automatically upon them visiting my hompage)

    That is the case If you have the “Auto locator” enabled in GEO my WP Settings page and in your form, under the “page load results” tab, you set it to display results based on the user’s current location.

    Do you have it setup this way?

    #50882
    gsh2000
    Member

    wow – thanks for quick response…. that was easy — [gmw search_results=”1″] worked fine for me…

    regarding Autolocator… yes, I have settings correct and search results *are working OK*, but it’s just that the autolocated address itself is not displayed… this is normal?

    I might do some more testing from different browsers, devices, but default autolocated address not showing in form field.

    GARRY

    #50883

    You are welcome Garry.

    yes, I have settings correct and search results *are working OK*, but it’s just that the autolocated address itself is not displayed… this is normal?

    It is indeed they way the plugin works at the moment. I will however add this fix to GEO my WP 3.0 which is under development.

    #51229
    gsh2000
    Member

    Eyal hello:

    Sorry to trouble you again on this, but after much further testing, found a strange behavior.

    [User’s current location based results=yes], only works OK when [Enable Page Load features = yes]

    i.e. If no data is entered into the form address field, and user clicks submit, The gmw_current_location is ignored, and **ALL** posts are listed in results.

    Only Auto-loading results appears to use my gmw_current_location.

    So when, for example, I have a form on my homepage and results on a separate page, if user clicks submit without entering an address, my results page is populated with *ALL* posts.

    Any suggestions? Prefer not to have to force user to enter address.

    Thanks, GARRY, Los Angeles
    GSH2000

    form/results on same page – form_id_1 – works OK
    Enable Page Load features = yes
    User’s current location based results=yes
    Results Page=samepage

    form and results on different pages (homepage–>resultspage) – form_id_2 – lists ALL posts
    Enable Page Load features = no
    User’s current location based results=yes
    Results Page=resultspage
    [gmw search_results=”2″]

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.