Forum: Bug Reports

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support and general questions related to GEO my WP plugin and its core add-ons please use the support forum.

[Resolved]Issue with gmw_get_post_info( $args ) and object caching

Forums Bug Reports Issue with gmw_get_post_info( $args ) and object caching

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #51977
    maelga
    Member

    Hi Eyal,

    I use <?php echo gmw_get_post_info( $args ); ?> in custom post type to display post addresses on front-end.
    Whenever object caching is enabled it returns the cached address and not the updated ones.
    On backend the addresses is updated and shows fine but on frontend, it’s the old address that shows.
    Once I manually flush the object cache, then the updated address shows fine on frontend.

    Have you already encountered this object caching issue?

    #52122

    Hi Maelga,
    I think I know where the issue is and I will provide a fix in the next release of the plugin. However, the next release is a major update and might take a couple of months to accomplish.

    If you are comfortable editing a code file I can guide you on how to temporary fix this issue.

    #52141
    maelga
    Member

    Hi Eyal,

    Yes, please I’m interested.
    I have implemented wp_cache_flush() on every save_post as a temporary workaround, but it is probably killing most of my object caching performance gain.

    #52175

    Hi Maelga,

    I have implemented wp_cache_flush() on every save_post as a temporary workaround

    That’s exactly the part that is missing in GEO my WP.

    Try the below as a temporary fix:

    1) Open the file geo-my-wp/plugins/posts/includes/gmw-pt-functions.php

    2) Change line 10 which should be

    to

    3) Save the file and test it.

    Let me know if that works.

    Thanks,

    #52295

    This topic marked “Resolved” due to inactivity. If you wish to reply to this topic please change its status to “Not resolved”  before replying.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.