GEO my WP Support

Use this forum for technical support and general questions related to GEO my WP plugin and its core add-ons only. For technical support and general questions related to any of the premium extensions please open a new premium support ticket.

[Resolved]Map not loading unless URL has a query string

Forums Support Map not loading unless URL has a query string

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #58825
    Carter
    Member

    Below are two URLs for the same page. When I include any query string, the map loads:

    1. No map. I see a spinning icon where I expect to see a map. https://www.oysterater.com/place/grand-central-oyster-bar/
    2. Same page. I see the map. Difference is the URL has a query string, which can be anything. https://www.oysterater.com/place/grand-central-oyster-bar/?abc123

    I’m using a shortcode in the template as follows, and have also tested the same shortcode, with same result, directly in post content:

    <?php echo do_shortcode('[gmw_single_location object="post" elements="address,map,directions_link,location_meta" info_window="title,address" location_meta="website" units="m" map_width="100%"]'); ?>

    Has anyone else experienced this particular issue with URL and query string? Thank you!

    #58832
    Carter
    Member

    Update: No remedy found yet. I’m running plugin version GEO my WP 3.2.1, and two extensions: Posts Locator, Single Location. I’ve tried deactivating, clearing caches, reactivating, clearing caches again. I’ve checked different browsers and get same results.

    What else should I try? It’s quite possible the theme (Divi) is doing something that conflicts, and I’ll be looking into that next.

    #58851
    Carter
    Member

    I never figured out the root cause, but I wrote an htaccess rule that fixed the issue. Here’s what I used in my htaccess:

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.