Forum: Nearby Posts

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Nearby Posts premium extension please open a new premium support ticket.

[Resolved]Nearby Locations not working!?

Forums Nearby Posts Nearby Locations not working!?

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #45860
    Eric Asleson

    On a page, I can try various shortcodes. Neither of these do anything but display the text as it looks here directly on the finished viewed page, which makes zero sense:

    — neither of these work —
    [gmw_nearby_locations element_id=”143″ item_type=”posts” nearby=”user” units=”miles” radius=”300″ orderby=”distance” order=”DESC” show_map=”true” no_results_message=”No results were found”]

    However, if I fill out a form and shortcode it, it works:
    [gmw form=”1″]

    I purchased the “Nearby Locations” and have the following activated in the add-ons area:
    Post Types Locator, Single Location, Current Location, Nearby Locations, Nearby Posts

    Private Content Hidden

    Hi Eric,

    Nearby Locations and Nearby Posts are the same add-ons but different versions. Nearby Posts was renamed to Nearby Locations in version 1.1 which is still in beta. And so only one of the two versions can be activated at a time.

    Also, please make sure that you download Nearby Locations 1.1-beta from Your Account page.

    Let me know if that helps.

    Eric Asleson

    Thank you for this! I followed your steps and it’s working now like I thought it should!

    Couple of new questions:

    1. When you click into a post from the map, it loads the posts page. Do you know how to get rid of the Leave a Reply? It’s turned off (commenting) from WP Admin Setting Discussion, but still appears here. And also Comments isnt part of the post from Screen Options.

    2. Do you know how to get the image “featured image” assigned to the post not to be full width and instead be medium to small size on the post page? I tried even editing the single-post file in your plugins folder but that didnt shrink it.

    3. Would you know how to alter it from saying “Tags” to instead not even show its label? And only show the tag itself? The prior 2 above are higher importance though.

    Eric Asleson

    Nevermind about #3 above, I’m using category instead of tags now. But, #1-2 I still need help on. Thank you!

    Eric Asleson

    By the way, I’m not sure you can help. These 2 things I’ve asked for your help on may be controlled by theme.


    HI Eric,
    Indeed both things you mentioned controlled by the theme so I can’t help you much.

    Comments should have a “Allow comments.” checkbox in the “Edit post” page of the admin. If this checkbox is checked the comments will show for that post regardless if the main “hide comments” option is set to true. If you don’t see the “Allow comments” checkbox in the “Edit Post” the page then at the top of the page you will see “screen options” button/toggle. Once you click on it you will see the different “Edit Post” page options which you can show/hide using checkboxes. Make sure the “Discussion” checkbox is checked. This checkbox will reveal the “Allow comments.” checkbox so then you could uncheck it.

    As for the feature image you will most likely need to adjust the size using some CSS if there are no settings for it in the theme settings.

    I tried even editing the single-post file in your plugins folder but that didn’t shrink it.

    Which single-post file are you referring to? GEO my WP doesn’t have such file.

    Eric Asleson

    I have one more brand new question:

    When filling out phone #’s and web address on posts for this geo plugin (image attached, red lined boxes), how do you get them to show up on the frontend? They don’t show up on the map, on the map result for posts box hover/popup icon, anywhere in the search results listings or category view, nor on the individual viewing of a single post (result) page.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.