Forum: Xprofile Fields

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Xprofile Fields premium extension please open a new premium support ticket.

[Fixed in the Next Release]Pagination and Members Per Page issue.

Forums Xprofile Fields Pagination and Members Per Page issue.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #41792
    Craig Moser
    Member

    Currently working on a project for a client who has a team of health coaches across the US. Each coach has profile page using buddypress. This is the current coaches main page where you can search for your coach. My main issue is the when you submit your search.  Click here to see the search I did . Currently on my Geo My WP search form setting I have it set to only show 24 members per page. While there are only 24 showing per page it says there is a total of 36 but there is not way of getting to them.

    If I change my setting to be 24 or 48 members per page it then shows a drop down to select how many members per page you want. If I click on 48 though it goes to a blank page.

    If I lower the number to like 4 members per page then I get a pagination to the right of the page that has previous – 1, 2, 3, 4, 5 – next. This does not show unless the member per page is real low.

    Ideally I do not want the option to show different amounts of members per page. I just want the pagination to the right. I would like 24 members per page.

    I have tried deactivating every plugin, defaulting to the wp themes, and reinstalling all of my geo my wp and buddypress plugins.

    Any suggestions would be great. Thanks.

    #41798

    Hi Craig,
    There is another user reported a similar issue. I am looking into this issue.

    #42706
    Craig Moser
    Member

    Hi I was just following up to see if there was a solution for this. Thank you.

    #42805
    softdesigns
    Member

    Hello-

    We have the same problem and have been waiting for a fix.  We temporarily “fixed” the problem by setting the number of members per page larger than our membership, but this fix won’t last long once we open our site to the public.

    Thanks for giving this your attention!

     

    #42955

    @Craig,
    I apologize for missing out your initial post. However, I think I finally found the issue. I wasn’t able to duplicate this issue, which was also reported by SoftDesigns in a different topic, until now.

    Until I release an official fix which probably will only be after the weekend you can try fixing it by editing one core file.

    Open the file geo-my-wp/includes/geo-my-wp-template-functions.php and in line 1058 which should be:

    remove the (int) so it will then be:

    save the file and give it a try.

    Let me know if that helps.

    Thanks.

    #43101
    softdesigns
    Member

    This sounds great, looks like we almost have a fix for the pagination/members per page problem!  Our file doesn’t have line numbers, so looking for that one line of code seems impossible.  We’ll just wait until you put out the next release which hopefully will fix the problem.  Let us know when it’s fixed.

    Thanks so much for all that you do!

     

    #43135
    Craig Moser
    Member

    Fix worked perfect for me. Thank you.

    #43239

    You are welcome @Craig. I am glad it is working.

    @SoftDesigns,
    I am still working on the next version. I hope to release it this week or during the weekend.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.