GEO my WP Support

Use this forum for technical support and general questions related to GEO my WP plugin and its core add-ons only. For technical support and general questions related to any of the premium extensions please open a new premium support ticket.

[Resolved]Search Resetting when click back button.

Forums Support Search Resetting when click back button.

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #57039

    Hi,

    I am using your plugin with WP job manager, and it’s awesome. One thing I am noticing, and need help fixing is when you click the back button in your browser.

    Scenario :

    I select a location, then some categories, and it will display a bunch of results.

    You click on a listing and it takes you to a single listing. Read the listing, and click the back button, it will then take you back to the search page.

    Problem is that it keeps the category selections, but the location is reset, so you have to filter the results again if you want to see another listing in a certain location.

    I contacted the WP Job Manager devs, and they pointed out that their filters keep the data, and it’s the location which resets, which would be your plugin.

    Could you help me fix this, please?

    YUou can see my site here

    #57041

    Hello Jonathan,

    Thank you for the feedback.

    What you described is not an issue with the plugin, but with how Google Address Autocomplete works.

    This questions has been asked before, and unfortunately, I was unable to find a solution or a work around for it.

    It seems that when Google Address autocomplete is enable, it prevents the address from being dynamically populated in the address field when using the browser’s back button.

    I can’t remember exactly, but I think it does work in some browsers.

    You can verify this by disabling the Address autocomplete feature and see that the location is preserved when going back to the search page.

    Unfortunately, this is not in my control.

    I will search for a solution again, now when you mentioned this again, but I am not sure if there is one.

    #57046

    Thanks, Eyal!

    I unchecked the autocomplete on the frontend, and it works just how i want it now.

    Would be great if you found a way to get this to work with the autocomplete on, but for what I need, this works great.

    Thank You again.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.