Forum: Xprofile Fields

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Xprofile Fields premium extension please open a new premium support ticket.

[Not resolved]Setting a Default Value in Search Form Usingmw_fl_xprofile_form_default_value

Forums Xprofile Fields Setting a Default Value in Search Form Usingmw_fl_xprofile_form_default_value

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #50500
    Mark Behnken
    Member

    Hi,

    Are there any examples of how to use the gmw_fl_xprofile_form_default_value filter? I am not a coder and have no clue how to proceed. I need to set a default field on the search form so only male or female members are shown. I set up an xprofile field called gender with a male and female value. Can you provide a sample function that shows me how to accomplishes this using that filter?

    Thank you,

    Mark

    #50522

    Hi Mark,
    The filter you mentioned will only effect the search query on page load when using the “Page load results” tab. If the form is submitted with data the filter won’t effect the results. Is that what you are looking to do or do you need the default values to effect the search query on form submission as well?

    #50528
    Mark Behnken
    Member

    Hi Eyal,

    Thank you very much for getting back to me. I will likely need to utilize both options as my project progresses as I’m going to be creating many different forms with different requirements. Would love to have an answer to both scenarios. Are you ok with providing that? Don’t mean to give you extra work. Really appreciate your help.

    Best Regards,

    Mark

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.