Forum: Geo Job Manager

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Geo Job Manager premium extension please open a new premium support ticket.

[Resolved]Some Locations Not Appearing on Map

Forums Geo Job Manager Some Locations Not Appearing on Map

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #53828
    Greg Barr

    Just installed the plugin, and added gjm_use=2 to the shortcode.

    Some of my jobs are showing up on map and in search results, but most aren’t.
    But when I search on their location, they show up.

    The default view of the map shows 10 jobs around the world, mostly in clusters of 2 or 3,
    but I have 32 jobs in the system that are approved and have locations.

    Why aren’t they showing up?

    (access to sandboxed site in private content)

    Private Content Hidden
    You must be logged in to view attached files.

    Hi Greg,
    The map is connected to the search form and synced with the search results below. The jobs that you see in the search results are the jobs that will show on the map. So you need to click the “Load more” button in order to see the rest of the jobs on the map.

    I hope that makes sense.

    Greg Barr

    Thanks for the prompt response. Yeah, it makes sense. Unfortunate though, as I like having the page load 10, with option to “load more.”

    I changed setting to load all 40 jobs, and my map rocks.

    With that addressed through workaround, I guess this becomes a feature request/suggestion: I wish there was an option to have the map display all jobs, while the list of openings below the map only shows the first 10.


    There is already an option Greg.

    You can use the shortcode

    To display a map of all jobs. So you can place this shortcode anywhere in your page and disable the map that is being produced by the [jobs] shortcode. This way the map will always display all locations regardless of what is being displayed in the search results.

    This is the docs page of the [gjm_jobs_map] shortcode.

    Let me know if that helps.

    Greg Barr

    I disabled the map that’s shown via [jobs] shortcode, and added the map above, and it’s showing up there now.

    By default it is appearing as a 250px by 250px square, and that’s not changing even when I set height and width using the gjm_map height and width shortcode elements prescribed on the docs page you lined.

    [gjm_jobs_map gjm_map_height=”300px” gjm_map_width=”100%”]


    Hello Greg,
    The shortcode attributes should be:

    Let me know if that helps.

    Greg Barr

    Worked like a charm, thanks much.


    You are very welcome Greg.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.