Forum Replies Created

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • in reply to: Remove Grouping Clusters #54006

    works for me…. thanks! I can finally put this project to bed…

    in reply to: Geocode Address Location is not geocoded. #53590

    Sorry for all of the posts… so I saw where Google won’t let you post more than 125 queries at a time. That probably explains why I get to 140 and it stops. I broke the import into chunks of 100 and I think it worked!!!! I hope this helps others.

    in reply to: Geocode Address Location is not geocoded. #53588

    Even all of the local ones are not actually geocoding. So why wont they geocode? We’re not anywhere near our limit of queries.

    in reply to: Geocode Address Location is not geocoded. #53587

    If I use the plugin I can geocode them by hand but there are hundreds of listings. Its not something the client is OK with and understandably so. Can you tell me why they won’t geocode on the live site but just fine locally?

    If you could provide step by step instructions how to import just the listings and their geodata, that would help. I’m still not getting all of the listings over or they are duplicated or not geocoding. I really don’t want to give up on this. If I move them over manually, the ones that are not geocoded won’t geocode at all. I’d like to think that the plugin would work as advertised ya know? So far, nothing has really worked for me. Its been brutal. Anything you can do to help would be great. I’d really like to know why they won’t geocode on import on the live site.

    in reply to: Geocode Address Location is not geocoded. #53538

    I tried to just export the posts from the install where it worked fine but the map doesn’t show when I import the posts. What else would need to be moved over if I do this manually? IE: where is the geocode data live?

    in reply to: JS error #53432

    Awesome. I wish I would have checked with you sooner… resolved… thanks a ton.

    in reply to: JS error #53391

    I installed the core control plugin and found this error

    {
    “error_message” : “This IP, site or mobile application is not authorized to use this API key. Request received from IP address 68.112.60.144, with empty referer”,
    “results” : [],
    “status” : “REQUEST_DENIED”
    }

    BUT I created a server key, verified the domain and everything. Yet the error persists. What is the deal on this? I’ve been working on this for 3 months… I’ve tried everything I can to get the right key to work.

    I added the below

    add_filter( ‘job_manager_geolocation_endpoint’, ‘add_geolocation_key_to_endpoint’ );

    function add_geolocation_key_to_endpoint( $endpoint ) {
    $endpoint = add_query_arg( ‘key’, ‘AIzaSyDgHTtCQocOedIcPV20DFJ8vpmbd3zeaiA’, $endpoint );
    return $endpoint;
    }

    Again, that is a server key (I tried a browser key too) and it has been verified.

    I can’t be the only person ever with this issue.

    Thanks,
    Andrew

    in reply to: JS error #53384

    Not sure why that link didnt make it over http://www.libertydirect.org/directory/

    in reply to: JS error #53375

    I meant to add, I have the same exact set up locally and on a staging server and it works fine. Same plugins, same theme, same everything. Even the staging server is on the same server as the production server. The only difference is that one has a domain and the others just IP addresses…

    in reply to: Error from API in browser #52639

    Just another day in the life… thanks for the hand. I’ll reach out to WPJM. I see some other folks having similar issues. I thought that functionality was coming from your plugin. Thanks again for the hand.

    in reply to: Error from API in browser #52632

    Are you using V2 or V3 of Google Maps API? I saw somewhere that V3 would made some adjustments for this limitation.

    Could you add an option for the plugin where users could use their own API key?
    Or a way to get the user to use a business account?

    Thanks,
    Andrew

    in reply to: Error from API in browser #52631

    Ugh, many hours later… the dedicated IP did not help. I set the entire site up using a dedicated IP and the issue persists.

    The listings are geocoded locally. So I thought, well I can use the export from the local version and import to the live version. Just Geocode locally… When I import the listings from the local set up where they are geocoded, they import into the live site NOT geocoded. How can that be possible? That tell me this is not the query limit if they are already geocoded and it may be something host related or something else in the environment. Any other ideas?

    Thanks,
    Andrew

    in reply to: Error from API in browser #52594

    I set things up locally and everything geocoded. So it may be the OVER_QUERY_LIMIT issue as you suggested.

    Would having the site on a dedicated IP address help at all here?

    in reply to: Error from API in browser #52574

    The plugin indeed worked. However, there are hundreds of posts. The whole project requirement was all about importing these using https://wordpress.org/plugins/wp-job-manager-xml-csv-listings-import/. Perhaps there is a setting or something in the import feature that is causing this?

    Is there a way to bulk geocode them? That would be perfectly fine.

    Any idea what causes some to not geocode and other to do so fine?

    Thanks,
    Andrew

    in reply to: Error from API in browser #52327

    The first warning is from Google Chrome browser. Google has disabled the browser locator for non secured pages. Which means that if your site does not have SSL certificate installed, then users won’t be able to use the current location feature. Unfortunately, there is nothing to do about that.

    I’m not sure I follow you on this. We do not have SSL installed but the locator seems to be working on some occasions.

    When the map is not showing most likely means that there is no location data saved in Job manager Geolocation table in database. Please navigate to the admin’s “Edit Job” page of the job with a missing map and click the “Update” button to re-save the job. By doing so it should trigger the geocoder and hopefully the location data will be created. You can confirm that the location data exits by looking for the custom fields geolocation_street, geolocation_city, geolocation_state and so on.

    Unfortunately, resaving did not do the trick. Even if it did, going into hundreds of locations and configuring each one is not realistic at all. The biggest issue is that they are not showing in the map either. So they dont show in the map nor does the map show. I’m missing more than half of my entries.

    If there is no location entered in the address field ( manually or using the locator ) then the default order by WP Job manager plugin is random. What have you tried to do in order to change that?

    I’m pretty sure these are not ordering because they are not geocoding for some reason. I bet once we get that map to show, they will order properly.

    That all being said, the most important thing here is to get this map to show. I’ve spent an enormous amount of time on this project. Whatever you can do to help me get this map working consistently would be awesome.

    Thanks,
    Andrew

Viewing 15 posts - 1 through 15 (of 18 total)